"docker (apple silicon/m1 preview) mysql “no matching manifest for linux/arm64/v8 in the manifest list entries”" Code Answer

4

well, technically it will not solve your issue (running mysql on arm), but for the time being, you could add platform to your service like:

services:
  db:
    platform: linux/x86_64
    image: mysql:5.7
    ...

alternatively, consider using mariadb, which should work as a drop-in replacement like e.g. this:

services:
  db:
    image: mariadb:10.5.8
    ...

both ways work for me on m1 with the docker preview

By grasbueschel on May 18 2022

Answers related to “docker (apple silicon/m1 preview) mysql “no matching manifest for linux/arm64/v8 in the manifest list entries””

Only authorized users can answer the Search term. Please sign in first, or register a free account.