Asked  1 Year ago    Answers:  5   Viewed   20 times

I've read the global installation documentation for Composer, but it's for *nix systems only:

curl -s https://getcomposer.org/installer | php
sudo mv composer.phar /usr/local/bin/composer

I would be such happy doing the same on Windows, that's the OS of my development machine. I would be able to run

composer update

From an arbitrary folder where composer.json exists. Interpreter php.exe is already in PATH variable.

Any clue?

 Answers

1

Sure. Just put composer.phar somewhere like C:phpcomposer.phar, then make a batch file somewhere within the PATH called composer.bat which does the following:

@ECHO OFF
php "%~dp0composer.phar" %*

The "%*" repeats all of the arguments passed to the shell script.

Then you can run around doing composer update all ya want!

Thursday, April 1, 2021
 
samayo
 
2

Assuming a regular composer installation, to rollback to version 1 of composer, you simply execute:

composer self-update --1

When you want to go back to version 2 (which you should, after updating or removing the incompatible plugins):

composer self-update --2

The above will take you to the latest on any of the two major versions.

You can also "update" to a specific version just by passing the version number to self-update:

composer self-update 1.10.12
composer self-update 2.0.7

And finally after performing any self-update, you can specify --rollback to go back to the previously installed version.

composer self-update
composer self-update --rollback

Finally, if you are feeling adventurous, you can update to a pre-release version by executing:

composer self-update --preview
Tuesday, June 29, 2021
 
etsous
 
2

Use TaskFactory.FromAsync to create a Task<Stream> from the BeginGetRequestStream/EndGetRequestStream methods. Then you can get rid of your OnGotWebRequest completely, and do the same thing for the response.

Note that currently you're calling EndGetResponse when a BeginGetRequestStream call completes, which is inappropriate to start with - you've got to call the EndFoo method to match the BeginFoo you originally called. Did you mean to call BeginGetResponse?

Monday, August 16, 2021
2

I suspect "php.ini-production" is a dummy configuration file suitable for live environments. Do a php -i at the console and find the 'php.ini' path, to see where it is expecting the ini file to be kept. This is normally expecting "php.ini", and may not actually exist - if it does not, copy php.ini-development (or similar) to the location required.

This is near the top of (a very long) output, so you may find redirecting it to a file helpful (php -i > C:phpinfo.txt).

Sunday, October 10, 2021
 
1

I just solved this problem. I downloaded the tar.gz file from PyPI, extracted it and edited the source files. To facilitate Windows support, cd into the package directory and then change line 31 in the setup.py file from extra_compile_args=['-Wno-cpp'], to extra_compile_args = {'gcc': ['/Qstd=c99']}.

Then you can install this package from the local source using pip install -e /path/cython_bbox-0.1.3.tar/dist/cython_bbox-0.1.3/cython_bbox-0.1.3. If successful, you should see the following:

Installing collected packages: cython-bbox
  Running setup.py develop for cython-bbox
Successfully installed cython-bbox

Here's a relevant thread for more info: https://github.com/cocodataset/cocoapi/issues/51

Hope this helps someone!

Thursday, November 25, 2021
 
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :